Aus dem Alltag eines IT'lers

UEFI bootet nur noch in SHELL

Nerdy Talk Dass ich kein Freund von UEFI bin, ist kein Geheimnis. Und ein erneutes Erlebnis bestätigte mir mal wieder meine Abneigung dagegen.
Ich wollte ein BIOS-Update meines MSI Boards durchführen und bootete daher ins BIOS, um mir die aktuelle Version auszulesen. Und als ich es wieder verlassen wollte (Exit without Changes) weigerte es sich. Ich landete nach der Bestätigung immer wieder im BIOS GUI. Also schaltete ich den Rechner einfach aus und fuhr in wieder hoch. Doch danach startete dieser lediglich in der UEFI Shell.
Ähh.....ok.

Ich tippte brav ein "exit" ein, um den Rechner neu zu starten, doch es passierte nichts. Also führte ich einen Reset durch und landete erneut in der SHELL, die mir die Wahl ließ, das Script zu beenden oder fortzufahren, doch egal was ich wählte, ich landete immer wieder in der Shell. Irgendwann jedoch gelang es mir nach einem "exit" ins GUI des BIOS zu kommen. Dort sah ich, dass meine SSD nachwievor als UEFI Datenträger zur Verfügung und auch an erster Stelle stand. Soweit sah's also gut aus. Aber was war das Problem ?
Aus dem BIOS kam ich wieder nicht und so führte ich erneut einen Reset durch, nach dem der Bildschirm jedoch nur schwarz blieb und die Lüfter auf voller Drehzahl liefen. Also ein erneuter Reset: wieder nur ein schwarzer Bildschirm. Und noch ein Reset und nur der Hinweis "A2" in der rechten, unteren Ecke. Also vom Strom getrennt, Stecker raus, Netzteil aus und nach 30 Sekunden alles neu gestartet. Ergebnis: UEFI Shell.
Uff!

In der Shell gab ich erstmal den Befehl zum Auflisten der Datenträger ein und auch dort sah erstmal alles gut aus. Was war jetzt das verdammte Problem ? Per "exit" Befehl kam ich wieder ins BIOS und schaute nach. Hatte sich etwas geändert, das ich gar nicht umgestellt hatte ? Und tatsächlich: aus unerfindlichen Gründen änderte sich eine Boot-Option, die jetzt eben für das Starten der Shell verantwortlich war und den Windows Start dadurch verhinderte. Ich stellte den Wert also wieder auf "Windows" um, speicherte und verließ das BIOS - diesmal erfolgreich - und siehe da: der Rechner fuhr wieder hoch.
Sagenhaft!

Weshalb sich dieser Wert nur durch das Betreten des BIOS umgestellt hat, weiß ich nicht. Ich weiß jedoch, dass ich erneut unnötige Zeit mit UEFI Kack' verschwendet habe und wir sicherlich keine Freunde mehr werden.

No comments

Add Comment

E-Mail addresses will not be displayed and will only be used for E-Mail notifications.
To leave a comment you must approve it via e-mail, which will be sent to your address after submission.
Enclosing asterisks marks text as bold (*word*), underscore are made via _word_.
Standard emoticons like :-) and ;-) are converted to images.
BBCode format allowed
Was ergibt 17+4 ?

Submitted comments will be subject to moderation before being displayed.