Aus dem Alltag eines IT'lers

Fehlschlag: Joomla 2.5 Upgrade auf 3.4

Verbuggt und zugenäht Neben einigen Joomla 3.x Installationen habe ich noch zwei Seiten mit Joomla 2.58 laufen, deren Umstellung/Upgrade ich jetzt mal angehen wollte, aber es sollte so sein wie immer: nichts geht (mehr).
Ich prüfte zunächst die Komponenten und Module und führte, soweit verfügbar, Updates durch. Danach machte ich, wie an empfohlen, folgende Einstellungen:

- Plugin "System - Angemeldet bleiben" deaktiviert
- Über "Erweiterung/Joomla Aktualisierung" in den Einstellungen den Supportzeitraum auf "kurz" umgestellt
- Über "Kontrollzentrum/Server" die Fehlerberichterstattung auf "Maximal" gestellt

Zudem machte ich einen SQL-Dump und speicherte ihn. Danach machte ich ein Vollbackup mit Akeeba und sicherte mir das komplette Installationsverzeichnis zusätzlich manuell über FTP.
Danach stieß ich das Update aus Joomla heraus an, doch bereits bei 38% erschien ein Fehler, dass ins Verzeichnis ../htdocs/logs nicht geschrieben werden könne und das war's. Der Updatevorgang war damit abgebrochen und die Seite nicht mehr normal aufrufbar.
Ich importierte danach meinen Dump und spielte via FTP wieder alle Dateien zurück, was aber nichts brachte. Auch ein Restore aus Akeeba war erfolglos. Toll.
Also leerte ich im nächsten Schritt meine Datenbank komplett sowie auch das FTP-Verzeichnis. Anschließen kopierte ich alles wieder zurück und importierte auch den SQL-Dump, doch erneut: nur Fehlermeldungen.
Und so leerte ich erneut alles und kopierte nun lediglich die "kickstart.php" von Akeeba, die Sprachdatei und mein Akeeba Backupfile ins Root und rief via www.meineseite.de/kickstart.php das Akeebascript auf. Dieses begann mit dem Extrahieren der Dateien und brach bei fast 90% ab, weil es nicht in die .htaccess unter ./htdocs/logs schreiben konnte. Klasse. Immerhin lagen aber die extrahierten Dateien vor und auch die Datenbank war wieder komplett.

Ein Aufruf der Seite brachte zahlreiche Fehlermeldungen, zeigte aber beim Runterscrollen immerhin den Content schon wieder an. Beim Betrachten der Meldungen fiel auf, dass sie sich alle auf die "j4age" Statistikkomponente bezogen, die nach dem Restore offenbar einen Fehler hatte. Also deinstallierte ich diese sowie die zugehörigen Module kurzerhand über's Joomla Backend, an dem ich mich wieder anmelden konnte.
Hiernach blieb nur noch ein kleiner Hinweis am oberen Bildschirmrand stehen, dass j4age nicht verfügbar sei, obwohl darauf referenziert wurde: "j4age component required but not installed" .
Also ging ich in die Datenbank, öffnete die Tabelle "com_extensions und löschte alle Einträge, die mit j4age zu tun hatten. Erst danach war alles wieder wie am Anfang und die Seite wieder ok.

So wie es aussieht muss ich mir eine andere Lösung für das Upgrade einfallen lassen. Eine Möglichkeit wäre noch die Verwendung von "JUpgradePro", doch die Komponente steht auf der Herstellerseite zum Download scheinbar nicht mehr zur Verfügung.
Und falls die Frage aufkommt, weshalb ich nicht alles von Grund auf neu aufsetze und einrichten, ist ganz einfach beantwortet: es ist schlichtweg zuviel Content (zudem noch zweisprachig), den ich weder neu schreiben, noch per Copy & Paste neu anlegen will.

No comments

Add Comment

E-Mail addresses will not be displayed and will only be used for E-Mail notifications.
To leave a comment you must approve it via e-mail, which will be sent to your address after submission.
Enclosing asterisks marks text as bold (*word*), underscore are made via _word_.
Standard emoticons like :-) and ;-) are converted to images.
BBCode format allowed
Was ergibt 17+4 ?

Submitted comments will be subject to moderation before being displayed.